CCNP - BGP Router Reflector

Lab 6 Router Reflector

Route reflector sebenarnya adalah router BGP yang diperbolehkan untuk melanggar aturan seperti ditulis diatas. Route reflector dapat melakukan routing update yang diperoleh dari iBGP peer ke iBGP peer yang lain dalam kondisi tertentu. Dengan cara ini, maka kebutuhan untuk topologi full-mesh dapat diatasi dan jaringan dapat diperbesar dengan mudah

Jenis peer ada 3,

-eBGP perr

-Router reflector peer

-Router reflector non client peer

Untuk topologi kita pakai 4 router

Langsung saja kita mulai

Pada i-BGP peernya harus full mesh
• R1 peers ke R2, R3, R4 
• R2 peers ke R1, R3, R4 
• R3 peers ke R1, R2, R4 
• R4 peers ke R1, R2, R3

Konfig IP pada router 3 dan 4, untuk router 1 dan 2 masih sama seperti sebelumnya


R3(config)#int ra f1/0, f0/0
R3(config-if-range)#no shutdown  
R3(config-if-range)#int f0/0
R3(config-if)#ip address 23.23.23.2 255.255.255.0
R3(config-if)#int f1/0 
R3(config-if)#ip add 34.34.34.3 255.255.255.0 

Konfigurasi BGP dan EIGRP pada router masing masing

R1(config)#router eigrp 10 
R1(config-router)#network 1.1.1.1 0.0.0.0 
R1(config-router)#network 12.12.12.1 0.0.0.0 
R1(config-router)#no auto-summary 
R1(config-router)#exit 
R1(config)#router bgp 1234 
R1(config-router)#neighbor 2.2.2.2 remote-as 1234 
R1(config-router)#neighbor 2.2.2.2 update lo0 
R1(config-router)#neighbor 2.2.2.2 route-reflector-client 
R1(config-router)#neighbor 3.3.3.3 remote-as 1234 
R1(config-router)#neighbor 3.3.3.3 update lo0 
R1(config-router)#neighbor 3.3.3.3 route-reflector-client 
R1(config-router)#neighbor 4.4.4.4 remote-as 1234 
R1(config-router)#neighbor 4.4.4.4 update lo0 
R1(config-router)#neighbor 4.4.4.4 route-reflector-client 
R1(config-router)#exit 

R2(config)#router eigrp 10 
R2(config-router)#network 2.2.2.2 0.0.0.0 
R2(config-router)#network 12.12.12.2 0.0.0.0 
R2(config-router)#network 23.23.23.2 0.0.0.0 
R2(config-router)#no auto-summary 
R2(config)#router bgp 1234 
R2(config-router)#neighbor 1.1.1.1 remote-as 1234 
R2(config-router)#neighbor 1.1.1.1 update-source lo0 
R2(config-router)#exit 

R3(config)#router eigrp 10 
R3(config-router)#network 23.23.23.3 0.0.0.0 
R3(config-router)#network 34.34.34.3 0.0.0.0 
R3(config-router)#network 3.3.3.3 0.0.0.0 
R3(config-router)#no auto-summary 
R3(config-router)#exit 
R3(config)#router bgp 1234 
R3(config-router)#neighbor 1.1.1.1 remote-as 1234 
R3(config-router)#neighbor 1.1.1.1 update-source lo0 

R4(config)#router eigrp 10 
R4(config-router)#network 4.4.4.4 0.0.0.0 
R4(config-router)#network 34.34.34.4 0.0.0.0 
R4(config-router)#no auto-summary 
R4(config-router)#exit 
R4(config)#router bgp 1234 
R4(config-router)#neighbor 1.1.1.1 remote-as 1234 
R4(config-router)#neighbor 1.1.1.1 update-source lo0 
R4(config-router)#exit 

Terakhir kita cek di semua router

R1#sh ip bgp summary 
BGP router identifier 11.11.11.11, local AS number 1234 
BGP table version is 1, main routing table version 1

Neighbor      V           AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down 
State/PfxRcd 
2.2.2.2        4      1234         4       4      1     0  0 00:02:33      0 
3.3.3.3        4      1234         4       4      1     0 0 00:02:31       0 
 4.4.4.4       4      1234         4       4      1     0 0 00:02:34       0 

R2#sh ip bgp summary 
BGP router identifier 22.22.22.22, local AS number 1234 
BGP table version is 1, main routing table version 1 
 Neighbor        V        AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down 
State/PfxRcd 
1.1.1.1        4      1234       10     10         1   0   0 00:08:58    0

Pengetesan, kita harus advertise suatu route di salah satu router dan kita pastikan bisa ping dari semua router.

R4(config)#interface Loopback44 
R4(config-if)#ip address 44.44.44.44 255.255.255.255 
R4(config)#router bgp 1234 
R4(config-router)#network 44.44.44.44 mask 255.255.255.255 

Setelah itu kita cek lagi di semua router

R1#sh ip bgp 44.44.44.44 
BGP routing table entry for 44.44.44.44/32, version 3 
Paths: (1 available, best #1, table Default-IP-Routing-Table, RIB-failure(17)) 
Flag: 0x820 
  Advertised to update-groups: 
       1 
  Local, (Received from a RR-client)  
  4.4.4.4 (metric 161280) from 4.4.4.4 (44.44.44.44) 
    Origin IGP, metric 0, localpref 100, valid, internal, best 

R3#sh ip bgp 44.44.44.44 
BGP routing table entry for 44.44.44.44/32, version 3 
Paths: (1 available, best #1, table Default-IP-Routing-Table, RIB-failure(17)) 
Flag: 0x820 
 Not advertised to any peer 
 Local 
    4.4.4.4 (metric 156160) from 1.1.1.1 (11.11.11.11) 
      Origin IGP, metric 0, localpref 100, valid, internal, best 
      Originator: 44.44.44.44, Cluster list: 11.11.11.11 

R2#ping 44.44.44.44 
Type escape sequence to abort. 
Sending 5, 100-byte ICMP Echos to 44.44.44.44, timeout is 2 seconds: 
!!!!! 
Success rate is 100 percent (5/5), round-trip min/avg/max = 28/32/36 ms












Komentar

Postingan populer dari blog ini

CCNP - HSRP IP SLA

CCNP - GLBP (Gateway Load Balancing Protocol)

CCNP - VRRP (Virtual Router Redundancy Protocol)